Sliding Door error after activation of theme

Everything else!

Sliding Door error after activation of theme

Postby inlina » Thu Aug 18, 2011 5:32 am

Hi,

I am getting the following error the moment I activate the Sliding Door theme:

Fatal error: Class 'Walker_Nav_Menu' not found in /home/inlina/xenonphoto.com.au/wp-content/themes/sliding-door/functions.php on line 123


I cannot access my Wordpress site or dashboard after I activate the theme. I have to delete the Sliding Door Theme folder, then I can get back to my dashboard to re-instate another theme. I had a look at the functions.php and, to be honest, I have no idea what the issue relates to as I really have no clue about PHP!

I am using Wordpress 2.8.6 and with PHP5.2.

Hope you can help me figure this one out as the theme looks fantastic.

Thanks,
Corey
inlina
I'm new here
 
Posts: 2
Joined: Thu Aug 18, 2011 5:17 am

Re: Sliding Door error after activation of theme

Postby inlina » Fri Aug 19, 2011 11:42 pm

Sorry, ignore this for now (unless you can help me with whta might be causing this in general). I have tried the theme on another website of mine and it works fine. Funny thing is both are set-up identically in the on my hosting, so perhaps one of my plugins is causing the problems (don't have the same plugins on both sites).

Thanks anyway.

EDIT: I am dumb....I was using a very old version of Wordpress wasn't I. One of the plugins I had active was 'Disable Wordpress Core Update', so I didn;t realise I was running such an old version. I best go and read Clues For The Clueless now.

CG
inlina
I'm new here
 
Posts: 2
Joined: Thu Aug 18, 2011 5:17 am

Re: Sliding Door error after activation of theme

Postby johnsen » Sat Sep 03, 2011 9:42 am

Hi Wayne, similar to inlina, I also encountered similar error message. Now, I could not access my wordpress admin login and website:

Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /home/qqmonkey/public_html/wp-content/themes/sliding-door/functions.php on line 205

I suspected that the error occured after I amended a line on the function.php. The said line amended as follows. The font in red is what I have amended:

<li class=\"bk1\"><a href=\""http://www.yummychitchat.com/categories/recipes\"\" style=\"background: url('".$theme_url."/imagemenu/images/2.jpg') repeat scroll 0%;\">slidingdoor</a></li>

Could you help me out soonest? Thank you.
johnsen
I'm new here
 
Posts: 3
Joined: Sat Sep 03, 2011 9:30 am

Re: Sliding Door error after activation of theme

Postby johnsen » Sat Sep 03, 2011 4:41 pm

johnsen wrote:Hi Wayne, similar to inlina, I also encountered similar error message. Now, I could not access my wordpress admin login and website:

Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /home/qqmonkey/public_html/wp-content/themes/sliding-door/functions.php on line 205

I suspected that the error occured after I amended a line on the function.php. The said line amended as follows. The font in red is what I have amended:

<li class=\"bk1\"><a href=\""http://www.yummychitchat.com/categories/recipes\"\" style=\"background: url('".$theme_url."/imagemenu/images/2.jpg') repeat scroll 0%;\">slidingdoor</a></li>

Could you help me out soonest? Thank you.


Hi Wayne, just to inform you that the problem on my website is solved. The problem indeed arised from the ammendment to the function.php. Blamed my itchy fingers. I have rectified the problem using the "file manager" on my webhost control panel.

Thank you anyway. You have designed a beautiful theme.
johnsen
I'm new here
 
Posts: 3
Joined: Sat Sep 03, 2011 9:30 am


Return to Announcements and General Support for Slidingdoor Themes