sliders not staying open on some category pages

Everything else!

sliders not staying open on some category pages

Postby AJMontag » Sat Sep 08, 2012 7:01 pm

My sliders link to a mix of category pages (using the 'page links to' plugin) as well as straight content pages.

The slides on the content pages stay open fine using the new "leave sliders open" option, but the slides linking to categories will not stay open but instead default to the first category page.

I have seven slides with respective pages numbered 0-6.

page number:
0 - category page - opens 1st slide (correct)
1 - category page - opens 1st slide (incorrect)
2 - category page - opens 1st slide (incorrect)
3 - content page - opens 4th slide (correct)
4 - content page - opens 5th slide (correct)
5 - content page - opens 6th slide (correct)
6 - content page - opens 7th slide (correct)

I've tried moving the various menus items around but get the same problem regardless. (always leaves open the first category slide)

My guess is that the slider is reading only the first level of the address (ie. site\category) and not drilling down to the next level where the respective categories are located (ie. site\category\example category), so the first page under the \category level is always the one that opens.

Is there a fix for this?
AJMontag
I'm new here
 
Posts: 1
Joined: Sat Sep 08, 2012 6:42 pm

Re: sliders not staying open on some category pages

Postby wayne » Mon Sep 17, 2012 10:05 pm

This functionality doesn't work if you use the 'page links to' plugin as there is no way of the theme knowing what page you are on!

So unfortunately it only works for posts and pages.
wayne
Site Admin
 
Posts: 727
Joined: Tue Apr 08, 2008 7:02 pm


Return to Announcements and General Support for Slidingdoor Themes



cron