Page 1 of 1

Sliding Doors - Help please

PostPosted: Wed Aug 29, 2012 3:24 pm
by NovaSC
Hi All... I have been having an issue with sliding doors... I have followed all the steps for changing the images ( created them in photoshop with the template, saved as JPG 320x200) went into each page and set the corresponding feature image..., created 2 menu's ( primary nav and sliding nav ) linked them up correctly. The sliders are not showing.. I have searched the forums and I see reference to changing code, but I assume that's older version code because I cannot find it in the header.php ...

Someone, please help, I have no idea what I did wrong and from what I can tell... I did it right.

Cheers and thanks in advance.

Update, I found this post but it didn't work:
Andrew P wrote:Nearly all this thread is completely redundant if you are on Version 3.
From what I can make out, header.php will display the image menu on every page.

If, like me, you do want to turn off the imagemenu on pages other than the home page, you will need to add something like this:
In header.php, around line 106 (in version 3.0.8), replace
Code: Select all
            <div id="imageMenu">

with
Code: Select all
            <div id="imageMenu"  <?php if (!is_home() && !is_front_page()) echo "style=\"display:none\" " ?> >

The reason I just do a display:none rather than skip over the menu creation call (which would save page load speed, depending on what can be cached by the browser) is that there is extra stuff that is being done further down in the php file, making this the simplest intervention.

Re: Sliding Doors - Help please

PostPosted: Thu Aug 30, 2012 3:32 pm
by clacasse
This probably won't be of much help, but I recently downloaded and installed the theme and everything is working great WITHOUT having to change any code. I made one careless error in not adding the correct pages to the slider menu, but that was a quick fix. Have you set the images on the slide pages to 'featured image?'